Qui n’a jamais essayé une application .NET sur un serveur ColdFusion?

Passé le cap de découverte de la nouvelle interface concoctée par “Billy”, où il n’est pas toujours facile de s’y retrouver … j’ai été confronté dernièrement à un problème attisant d’abord curiosité puis très rapidement agacement. gggrrrrr!

Voilà. Après avoir installé CF9 multi-servers sur un Windows 2008 R2 Std, sans problème particulier, j’ai entrerpris l’installtion de XenApp 6.5 (Citrix) toujours sous IIS 7. Une fois l’installtion finalisée, le site web XenApp, écrit en .NET, me renvoyait une magnifique marque de sympathie :  -> Error 500 !

Je dois avouer que quelques heures ont été nécessaires pour démontrer que ColdFusion n’était pas vraiment étranger à l’affaire. En effet, en supprimant les connecteurs IIS avec l’outil wsconfig,   le site XenApp fonctionnait normalement. Il semble donc que ColdFusion s’accapare les connecteurs et classes associées empêchant toute exécution de l’application .NET sur un même site IIS (celui par défaut). ColdFusion tenterai-t-il d’exécuter lui même le code .NET, le bougre ?!

J’ai donc organisé les règles de vie et de cohabitation dans la maison IIS 7 et le problème a été réglé en affectant, pour chaque environnement son propre web site IIS :
- un pour .NET (celui par défaut)
- et un autre pour ColdFusion
Chacun sa chambre !

Bon, et puis comment en vouloir vraiment à ColdFusion de vouloir empêcher toute cohabitation avec .NET? On aurait même une pointe de honte quand on y pense. Mon serveur ‘Kolfu’ a été véxé, bien sûr! Comment n’ai-je pas percuté plus tôt? Il a tellement l’habitude de faire toujours le boulot seul, qu’il a pris tout ce qu’il y avait à exécuter : le cfm, le cfc, l’aspx et tout le reste… Je lui est donc dis de se calmer, que ce n’était pas vraiement une infidélité de ma part, qu’il fallait s’ouvrir au autres (technologies), qu’il y avait maintenant un petit copain dans la boi-boite et qu’il fallait bosser ensemble.

Bvamax

 

 

 

 

 Last News